漏洞信息详情

Memcached 缓冲区错误漏洞

漏洞简介

Memcached是美国布莱德-菲兹派翠克(Brad Fitzpatrick)软件开发者的一套高性能的分布式内存对象缓存系统。该系统通过在内存中缓存数据和对象来减少读取数据库的次数,从而提高网站访问速度。

Memcached 1.5.16版本中的memcached.c文件的‘conn_to_str’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/memcached/memcached/commit/554b56687a19300a75ec24184746b5512580c819

受影响实体

    暂无