漏洞信息详情

FontForge 缓冲区错误漏洞

漏洞简介

FontForge是一款开源的支持多种语言的字体编辑工具。

FontForge 20190801及之前版本中的prefs.c文件的PrefsUI_LoadPrefs存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/fontforge/fontforge/pull/3886

参考网址

来源:github.com

链接:https://github.com/fontforge/fontforge/pull/3886

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-15785

受影响实体

    暂无