漏洞信息详情

ncurses crate for Rust 缓冲区错误漏洞

漏洞简介

ncurses crate for Rust是一款基于Rust的、用于编写独立于终端的基于文本的用户界面的库。

ncurses crate for Rust 5.99.0及之前版本中的instr和mvwinstr存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://github.com/jeaye/ncurses-rs

受影响实体

    暂无

补丁

    暂无