漏洞信息详情

wolfSSL 缓冲区错误漏洞

漏洞简介

wolfSSL(前称CyaSSL)是美国wolfSSL公司的一个针对嵌入式系统开发人员使用的小的、可移植的嵌入式SSL编程库。

wolfSSL 4.1.0版本中的wolfcrypt/src/asn.c文件的DecodeCertExtension存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://www.wolfssl.com

参考网址

来源:github.com

链接:https://github.com/wolfSSL/wolfssl/issues/2421

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-15651

受影响实体

    暂无

补丁

    暂无