漏洞信息详情

Poppler 数字错误漏洞

漏洞简介

Poppler是一个用于生成PDF的C++类库,该库是从Xpdf(PDF阅读器)继承而来。

Poppler 0.78.0及之前版本中的SplashOutputDev.cc文件的‘SplashOutputDev::tilingPatternFill’函数存在数字错误漏洞。该漏洞源于网络系统或产品未正确计算或转换所产生的数字。攻击者可利用该漏洞导致整数溢出或符号错误等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://gitlab.freedesktop.org/poppler/poppler/merge_requests/317

受影响实体

    暂无