漏洞信息详情

libmodbus 缓冲区错误漏洞

漏洞简介

libmodbus是一款使用C语言编写的,能够根据Modbus协议发送/接收数据的库。

libmodbus 3.0.7之前版本和3.1.5之前的3.1.x版本中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://libmodbus.org/2019/stable-and-development-releases/

受影响实体

    暂无