漏洞信息详情

GNU gdb 缓冲区错误漏洞

漏洞简介

GNU gdb是GNU计划的一款GNU项目调试器。它支持调试C、C++、Pascal以及FORTRAN等编程语言。

GNU gdb中的主要模块存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://www.gnu.org/s/gdb/

参考网址

来源:sourceware.org

链接:https://sourceware.org/bugzilla/show_bug.cgi?id=23657

来源:www.gnu.org

链接:http://www.gnu.org

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-1010180

来源:www.securityfocus.com

链接:https://www.securityfocus.com/bid/109367

来源:access.redhat.com

链接:https://access.redhat.com/security/cve/cve-2019-1010180

受影响实体

    暂无

补丁

    暂无