漏洞信息详情

Jsish 缓冲区错误漏洞

漏洞简介

Jsish是一款使用C语言编写的、内置数据库的小型JavaScript解析器。

Jsish 2.4.77_2.0477版本中的‘lexer_getchar’函数(jsiLexer.c文件)存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://jsish.org/fossil/jsi/tktview/3a069014976f3422d9d96821dc555c8326c02ae3

受影响实体

    暂无