唯嘉利亚云安全 提供服务器维护、网站开发,网站安全运维,安全托管等服务!

gdnsd 缓冲区错误漏洞


文章来源:唯嘉利亚云安全   发布时间: 2019-09-18  已有 14 人 阅读

漏洞信息详情

gdnsd 缓冲区错误漏洞

漏洞简介

gdnsd是一款使用C语言编写的DNS服务器。

gdnsd 3.2.1之前的3.x版本中的zscan_rfc1035.rl文件的‘set_ipv4()’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://gdnsd.org/

参考网址

来源:MISC

链接:https://github.com/gdnsd/gdnsd/issues/185

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-13951

受影响实体

    暂无

补丁

    暂无


【版权声明】:除非注明,唯嘉利亚云安全文章均为原创,转载请以链接形式标明本文标题和地址
原文标题:gdnsd 缓冲区错误漏洞
原文地址:https://www.vgaliya.com/cve-9336.html


文章标签: