唯嘉利亚云安全 提供服务器维护、网站开发,网站安全运维,安全托管等服务!

netfilter iptables 缓冲区错误漏洞


文章来源:唯嘉利亚云安全   发布时间: 2019-09-18  已有 19 人 阅读

漏洞信息详情

netfilter iptables 缓冲区错误漏洞

漏洞简介

netfilter是一款使用在Linux系统中的数据包过滤框架。iptables是其中的一个模块。

netfilter iptables 1.8.2版本中的iptables-restore存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://git.netfilter.org/iptables/commit/iptables/xshared.c?id=2ae1099a42e6a0f06de305ca13a842ac83d4683e

受影响实体

    暂无


【版权声明】:除非注明,唯嘉利亚云安全文章均为原创,转载请以链接形式标明本文标题和地址
原文标题:netfilter iptables 缓冲区错误漏洞
原文地址:https://www.vgaliya.com/cve-9543.html


文章标签: