唯嘉利亚云安全 提供服务器维护、网站开发,网站安全运维,安全托管等服务!

Squid 缓冲区错误漏洞


文章来源:唯嘉利亚云安全   发布时间: 2019-09-18  已有 18 人 阅读

漏洞信息详情

Squid 缓冲区错误漏洞

漏洞简介

Squid是一套代理服务器和Web缓存服务器软件。该软件提供缓存万维网、过滤流量、代理上网等功能。

Squid 4.0.23版本至4.7版本中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/squid-cache/squid/commits/v4

参考网址

来源:github.com

链接:https://github.com/squid-cache/squid/commits/v4

来源:www.squid-cache.org

链接:http://www.squid-cache.org/Versions/v4/changesets/squid-4-7f73e9c5d17664b882ed32590e6af310c247f320.patch

来源:www.squid-cache.org

链接:http://www.squid-cache.org/Advisories/SQUID-2019_6.txt

来源:www.squid-cache.org

链接:http://www.squid-cache.org/Advisories/SQUID-2019_5.txt

来源:www.squid-cache.org

链接:http://www.squid-cache.org/Advisories/SQUID-2019_3.txt

来源:www.squid-cache.org

链接:http://www.squid-cache.org/Advisories/SQUID-2019_2.txt

来源:www.squid-cache.org

链接:http://www.squid-cache.org/Advisories/SQUID-2019_1.txt

来源:lists.squid-cache.org

链接:http://lists.squid-cache.org/pipermail/squid-announce/2019-July/000100.html

来源:usn.ubuntu.com

链接:https://usn.ubuntu.com/4065-1/

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/Squid-buffer-overflow-via-Basic-Authentication-HttpHeader-getAuth-29761

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/153685/Ubuntu-Security-Notice-USN-4065-1.html

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.3226/

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-12527

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.2609/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.2692/

来源:www.securityfocus.com

链接:https://www.securityfocus.com/bid/109143

受影响实体

    暂无


【版权声明】:除非注明,唯嘉利亚云安全文章均为原创,转载请以链接形式标明本文标题和地址
原文标题:Squid 缓冲区错误漏洞
原文地址:https://www.vgaliya.com/cve-9577.html


文章标签: